Triodos - Full service outage

Incident Report for Tink providers Netherlands

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted May 14, 2026 - 11:57 CEST

Investigating

We are currently investigating an issue with Triodos.
- Affected users: [100]%
- Affected flow: Authentication, Payment Initiation, Refresh flow
- Start Time: [13/05/2026 [14:00] CET
- Bank side error: certificate issues on payments API
- Provider name: [nl-triodos-ob]
Posted May 13, 2026 - 14:24 CEST
This incident affected: Triodos.