Knab major outage
Incident Report for Tink providers Netherlands
Resolved
This incident has been resolved.
Posted Jun 28, 2022 - 11:33 UTC
Investigating
We are currently investigating an issue with Knab.
Posted Jun 28, 2022 - 08:46 UTC
This incident affected: Knab.