Triodos PIS - Major outage

Incident Report for Tink providers Netherlands

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 11, 2026 - 12:09 CEST

Investigating

We are currently investigating an issue with Triodos.
- Affected users: 100%
- Affected flow: Payment Initiation|flow
- Start Time: 10/05/2026 11:36 CET
- Bank side error: certificate issues on payments API
- Provider name: nl-triodos-ob
Posted May 10, 2026 - 14:46 CEST
This incident affected: Triodos.