Revolut Open Banking - Major Outage affecting Payment Initiation

Incident Report for Tink providers Netherlands

Resolved

This incident has been resolved.
Posted Sep 29, 2023 - 15:00 CEST

Identified

We have identified the issue and are in contact with Revolut Open Banking for further information.
We will update when a significant change to the situation occurs.
Posted Sep 29, 2023 - 14:45 CEST
This incident affected: Revolut.