Rabobank open banking - degraded performance
Incident Report for Tink providers Netherlands
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 21, 2024 - 15:45 UTC
Investigating
We are currently investigating an issue with Rabobank.
Posted Apr 19, 2024 - 16:01 UTC
This incident affected: Rabobank.